Ноябрь 9, 2018

Часть сайтов на WordPress станут небезопасными

Совсем скоро веб-ресурсы на базе WordPress PHP 5.6 и PHP 7.0 в декабре 2018 года станут менее защищенными. Эти версии перестанут получать обновления безопасности. Около 57 % всех сайтов на WP используют эти версии.

Чем это грозит владельцам? Кроме того, что сайты станут уязвимыми для вирусов и хакеров, они могут быть понижены в поисковой выдаче. Также прогнозируют сбои в работе некоторых плагинов.

Даты прекращения выхода обновлений:

  • 3 декабря — для версии WordPress PHP 7.0;
  • 31 декабря — для PHP 5.6.

Всем вебмастерам рекомендуем как можно скорее обновить WP до последней версии.

Как определить версию PHP на вашем сайте

Посмотреть, какую версию вы используете в данный момент, можно в панели хостинга. Просто зайдите в раздел, посвященный PHP. Или запросите информацию у службы технической поддержки вашего хостинга.

Другой способ — задействовать специальные плагины, такие как WordPress phpinfo.

Обновляем PHP на сайте до новейшей версии

Перед началом обновлений не забудьте сделать резервную копию сайта.

Просмотрите все установленные плагины для WordPress и проверьте их совместимость с последней версией PHP. Некоторые плагины не обновляются в течение длительного времени. Если какой-то из них несовместим с PHP 7.2, лучше заменить его на аналог. Использование несовместимых — потенциальная угроза безопасности.

Теперь можно обновлять PHP до последней версии. Сделать это нужно в панели хостинга в соответствующем разделе. При возникновении трудностей обязательно обратитесь в техподдержку вашего хостинг-провайдера.

Часть сайтов на WordPress станут небезопасными

Scroll Up